Calendar Vs Event List
  • Power User
    Posts: 47
    Topics: 14
    Eugen February 17, 2013

    Hello

    I posted this question two days ago and no answer yet… How often is the forum checked?

    I would like to have the possibility to have the events display in Calendar format. However, when I choose that, NOTHING is displayed.

    Advice?

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 18, 2013

    Hi Eugen, sorry for the delay.

    Please note however that we don’t operate 24/7. (Although there might be one or two exceptions where you get lucky) we typically keep a normal working week and, within that constraint, try to reply to customers within 24hrs of them posting here on the forum.

    I would like to have the possibility to have the events display in Calendar format. However, when I choose that, NOTHING is displayed.

    OK, so I visited your site using the URL you supplied when you created this thread but couldn’t locate your events pages. Can you provide a URL either to the page that ought to house your calendar view, or else to the upcoming events list, or even to a single event?

    Also, I notice your site seems to operate in two languages. Can you confirm if you are using a multi-language plugin to facilitate this (and, if so, which one are you using)?

    Thanks!

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 18, 2013

    Hey Barry

    THank you for your reply.
    The link would be http://www.eugenpopa.com/events
    I use WPML plugin for multiple languages

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 18, 2013

    OK – and if you login and visit Events > Settings > General what is Default view for the Events set to?

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 18, 2013

    Right now it is set to Event List.
    If it makes any difference, the Show Events Calendar Link is also checked.

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 18, 2013

    Can you also let me know which template you are using (and can you try changing this to Default Events Template if you haven’t already done so, otherwise try a few other settings)?

    The relevant admin page is Events > Settings > Template.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 18, 2013

    Right now it is default Page template.
    If I put default events everything gets messed up…

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 18, 2013

    I put it now on the Event Default Page for you to take a look
    http://www.eugenpopa.com/events

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 18, 2013

    Thanks Eugen.

    I think to bring the default event page into line we’d need to make a few changes to your custom ecp-page-template.php (please see our themer’s guide and tutorial on template overrides for more on this, if you’re interested).

    Otherwise I suspect we might need to add some new CSS rules to make the default page template play nicely … could I ask you to switch things back so I can take another look at that?

    With all that said, though, I’m worried that the month view is inaccesible due to a conflict with WPML. I’m just chatting with other members of the team about that to see what we might be able to do there.

    Are you in a position to (temporarily) deactivate WPML, flush the permalinks (by logging in and visiting Settings > Permalinks – you don’t actually have to save or change anything) then test if the month view becomes accessible? That would just help to narrow down the problem.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 20, 2013

    Hey Barry

    I deactivated WPML (didn\’t know how to flush permalinks though) and then I checked the events page. It looked messy.
    I turned the WPML back on and then selected the Default Page Setting and now it looks ok.
    ANother issue is that it shows only 2 events, but I have three and more in the making.
    Would it be easier/faster for you if I would give you the login to the site and you enter and fix it like that?

    Thank you

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 21, 2013

    Hey Barry,

    Let me know when you have some CSS for me :)

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 21, 2013

    I was just taking another look, I think you’ve got an error relating to a different plugin though that makes it difficult to assess how things look:

    http://eugenpopa.com/events/month/

    Also, what’s confusing me on this page (which seems to be your upcoming events view) is that, default page template or not, elements of markup I’d expect to see are missing.

    Have you made any customizations? What happens if you take things back to a basic state by deactivating all other plugins and switching to a default, unmodified theme such as Twenty Eleven or Twenty Twelve – does The Events Calendar work as you would expect then?

    If so, can you reactivate everything one-by-one and figure out what components might be causing problems? I’m basically wondering if there are a number of different conflicts going on here.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 21, 2013

    Ok
    I can play with the plugins and turn them off/on and see what gives and will get back to you.

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 22, 2013

    Great, look forward to hearing from you.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Ok

    I just did it. Deactivate ALL the plugins.
    I have two Event Tribe plugins.
    The The Events Calendar and The Events Calendar PRo.
    If I deactivate The Events Calendar, then nohting will show so I have to have BOTH of them installed and active (that is weird right?).

    So, with both of them active, the Default Events Page still looks bad.

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 22, 2013

    Yep you’re right, sorry I should have been clearer – there was no need to deactivate The Events Calendar/Events Calendar PRO, both need to be active.

    One thing I’m not clear on is, did you try switching to a default, unmodified theme like Twenty Eleven? I’m still curious as to why the “Events List” and “Calendar” buttons aren’t showing here.

    Are you also aware of the error displaying here? Seems to relate to a different plugin (“Exponent Web Media Pinterest?”) but it’s impacting on an events page, so it’s worth taking note of.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Hey Barry
    I am aware of the Pinterest issue.
    I can use the twenty ten template if you. Should I do that disabling ALL the plugins again?

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 22, 2013

    Yes, please deactivate all other plugins (except for The Events Calendar and Events Calendar PRO) and switch to a default, unmodified theme :-)

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    ok
    check back in 1 min

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Done

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Please let me know when you are done with it as I do not wish to keep my site with that template for long

    Thank you

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    I just selected now to see the events page in calendar view and it shows a bunch of errors

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/eugenpop/public_html/wp-includes/post-template.php on line 1039

    Warning: in_array() [

    And it goes on and on like that

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 22, 2013

    Yep, I noticed that and am discussing it with the team right now. Please do bear with me and I’ll get back to you as soon as I can (which may be Monday of next week, at this point).

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Ok
    Thank you for the heads up.
    I appreciate it.

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 22, 2013

    (And thank you for running through those steps. I appreciate you wouldn’t want to keep the site in that state.)

    It would be really useful to learn more about your hosting environment, if you aren’t adverse to sharing this information could you point us to the hosting company/package you are using.

    If you are happy to share this information but would rather not do so publicly, please email me at pro@tri.be instead, marking your email for my attention.

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 22, 2013

    Will email you now.

    Thank you

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 25, 2013

    Hi Eugen. Although when you switched to a default theme a different error occurred, everything else seemed to work correctly.

    What I’m unclear on is if this problem happens only with your theme or if another plugin is impacting. When you reactivated everything did you do so one component at a time and if so were you able to isolate the source of the problem to your theme or to a specific plugin?

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 25, 2013

    Hey Barry
    So, All plugins OFF.
    Keeping my theme (personality theme from gabfire), Calendar does NOT look perfect. Please refer to the screenshots I provided provided:

    http://imageshack.us/a/img805/7413/screenshot20130223at123.png
    http://imageshack.us/a/img856/7413/screenshot20130223at123.png

    So that means that from the get go, the Events Calendar does not fit perfectly with the theme. I would say that that should be our starting point.

    THoughts?

    Thank you

  • Power User
    Posts: 47
    Topics: 14
    Eugen February 25, 2013

    Again, tested
    Plugins = Off
    Theme = TwentyEleven
    List view – OK
    Calendar view = Mess

    Please see the printscreen:
    http://img705.imageshack.us/img705/4205/calendarview.png

  • Support Team
    Posts: 9344
    Topics: 5
    Answers: 973
    Barry February 25, 2013

    OK, so your initial problem was that the calendar (month) view wouldn’t show up:

    I would like to have the possibility to have the events display in Calendar format. However, when I choose that, NOTHING is displayed.

    If that is resolved – or you’ve confirmed that another plugin rather than your theme is causing the problem – then we can get cracking with your theme.

    So that means that from the get go, the Events Calendar does not fit perfectly with the theme. I would say that that should be our starting point.

    OK, so can you send across your theme so I can take a look (pro@tri.be, marking your email for my attention and linking to this thread)? Thanks!

  • Viewing 30 posts - 1 through 30 (of 46 total)

This topic is closed